Gegen Internetzensur
Stoppt die Vorratsdatenspeicherung! Jetzt klicken & handeln!Willst du auch bei der Aktion teilnehmen? Hier findest du alle relevanten Infos und Materialien:
  • Flickr Photos

    www.flickr.com
22. Jan
Don

mac@ubuntu:/$ Neue Webcam, kurzer Ärger

Eben meine neue Quickcam Pro 9000 an die Ubuntukiste gestöpselt und nix ging. Hab’s mit EasyCam2 probiert, der hat sie zumindest gleich korrekt erkannt, aber danach gab’s trotzdem kein Bild. Dann folgenden Tipp gesehen:

Try “sudo modprobe videodev”,
then “sudo modprobe uvcvideo”.

Und voilá, alles geht. Bei 1600x1200er Auflösung is das Ding zwar langsam ohne Ende, aber dafür gestochen scharf. Net übel.

Nachtrag: Um die Module bei jedem Systemstart zu laden, einfach die Modulnamen videodev und uvcvideo in die Datei /etc/modules eintragen. (Debian/Ubuntu) Siehe auch diese Seite.

Nachtrag: Das Problem hat sich auf meiner Kiste ja erledigt, aber vielleicht hilft jemand anderem dieser Link hier auch noch weiter.

7 Antworten zu „mac@ubuntu:/$ Neue Webcam, kurzer Ärger”

  1. #1~Balu

    Und ab welcher Auflösung läuft sie flüssig?

  2. #2~Markus

    Hm, unter Windows gibt’s da mehrere Faktoren; Wenn du zum Beispiel den “RealLight”-Modus einschaltest, wird die Belichtungszeit der Kamera auf das Umgebungslicht angepasst und damit verlangsamt sich auch die Framerate. Bei normalem Licht läuft die Kamera ansonsten aber auch mit ihren (interpolierten) 1600×1200 Pixeln flüssig.

    Linux checke ich gleich nochmal.

  3. #3~Markus

    Ein bissel ernüchternd isses schon, flüssig kriege ich das Bild (unter Linux, 8.10er Ubuntu, Stand 23. Januar 2008) momentan bei keiner Auflösung, ich würde schätzen, das sind so um die 12 FPS. Bis 960×720 kannste dann gehen, danach folgt nur noch der 1600er-Modus. Muss mal schauen, vielleicht ergibt sich noch was bei weiterer Recherche.

  4. #4~Markus

    (Also luvcview vermeldet 5-10 FPS bei 640×480 in meiner derzeitigen Konfiguration)

  5. #5~Markus

    Okay, letzter Nachtrag soweit – es lag an den Auto Exposure-Einstellungen. Kann es noch nicht genau festnageln, habe jetzt aber mit einem Bisschen Herumgespiele die automatische Belichtungssteuerung abschalten können und nun läuft das Video bei jeder Auflösung fließend, das heißt mit 15-20+ Frames.

    uvcdynctrl -s 'Exposure, Auto Priority' 0
    uvcdynctrl -s 'Exposure, Auto' 3
    uvcdynctrl -s 'Exposure (Absolute)' 70
    luvcview -s 1600x1200

    Habe dafür uvcdynctrl mit uvcvideo aus dem alten Berlios-Repository gebaut und danach das uvcvideo-Modul aus dem “neuen” Repository gebaut (R1269) und installiert; Kernel ist 2.6.27-11.

  6. #6~Balu

    Besten Dank für den ausführlichen Test.

    Die Kamera steht nämlich auf meiner “tobuy”-Liste. :-)

    Balu

  7. #7~Markus

    Du bist willkommen, oder wie die Amis sagen.

    Der Gesichtserkennungsmodus ist ein bissel affig, weil die Kamera dann automatisch deinem Gesicht (oder dem, was sie dafür hält) hinterherzoomt; Der Autofokus ist auch nicht unbedingt schnell, aber das isser ja bei normalen Fotoapparaten auch nicht. :) Ansonsten ne feine Sache.